Categories
Raspberry Pi User Help

Wolfram-engine failed to create symbolic link while doing dist-upgrade on Raspbian-stretch

I tried to upgrade my Raspbian on Raspberri Pi 3 from Stretch to Buster but receive this error: ➜ ~ sudo apt dist-upgrade -y Reading package lists… Done Building dependency tree Reading state information… Done Calculating upgrade… Done The following package was automatically installed and is no longer required: libmicrodns0 Use ‘sudo apt autoremove’ to […]

Categories
Raspberry Pi User Help

Windows 10 Setup on Pi Zero not working

I’m trying to set up a Raspberry Pi Zero (not a Zero W) with Raspberry Pi OS Lite (32-bit), headless through USB. I’m not great with computers (using CMD is a real headscratcher for me), to put this in perspective, and was hoping to use this Pi to boot up and run a single .exe […]

Categories
Raspberry Pi User Help

Namespace commands configure veth0 with a 169.254.x.y address

While experimenting with Namespace setup found that the following commands consistently configure veth0 with a 169.254.x.y address. I’ve checked everywhere in the system and cannot find a reference to it. Any ideas on what is going on here? sudo ip link add169.254 veth0 type veth peer name veth1 sudo ip netns add myvpn sudo ip […]

Categories
Raspberry Pi User Help

UV4L Streaming SSL enabled but I get SSL_ERROR_BAD_CERT_DOMAIN

when I run uv4l it seems work fine I created certificates for SSL with letsEncrypt: letsencrypt certonly –standalone -d mysafehouse.hopto.org –preferred-challenge dns mysafehouse.hopto.org is a domain created using www.noip.com and I registered it on my router. I also redirected on my router ports 80 and 443: Then I configured uv4l-raspicam.conf: #HTTPS options: server-option = –use-ssl=yes […]

Categories
Raspberry Pi User Help

UV4L Streaming SSL enabled but I get SSL_ERROR_BAD_CERT_DOMAIN

when I run uv4l it seems work fine I created certificates for SSL with letsEncrypt: letsencrypt certonly –standalone -d mysafehouse.hopto.org –preferred-challenge dns mysafehouse.hopto.org is a domain created using www.noip.com and I registered it on my router. I also redirected on my router ports 80 and 443: Then I configured uv4l-raspicam.conf: #HTTPS options: server-option = –use-ssl=yes […]

Categories
Raspberry Pi User Help

Console login when password contains British Pound Sterling (£) character

When setting up my Pi, I set my password before changing the keyboard type and layout and rebooting. My password now contains a British Pound Sterling (£) symbol where I had intended to type an octothorpe/hash (#). How do I now type "£" at the console to log in when there is no such key […]

Categories
Raspberry Pi User Help

PyAlsa not working in Buster – missing libasound.so?

I have been trying to run an audio capture program that has worked (for other people) on a Pi4. Looking at the PyAlsa documentation suggests that /usr/lib/libasound.so needs to be present. It is not. Running "find libasound.so" shows it is not present in Buster, even after running sudo apt-get install libasound2-dev. Looking at Debian for […]

Categories
Raspberry Pi User Help

Writing Firmware for the Raspberry Pico [closed]

I ordered a Rasperry Pi Pico to do some firmware development stuff on it, since I’m really interested in such things. Unfortunately, the pico wasn’t delivered so far and he won’t come in the near future (long story) Should I just start write some code using only the datasheets or should I wait until the […]

Categories
Raspberry Pi User Help

How to format csv data in Python after connecting a Arduino to a RPi? [closed]

Have connected a Arduino/Adafruit Feather nRF52840 Sense to a RPi 3 via a USB A to Micro B Cable and am saving Adafruit sensor data to a csv file on the RPi. Would appreciate help with formatting the temperature, pressure, and altitude data as integers, each reading separated by commas, and in rows each comprised […]

Categories
Raspberry Pi User Help

I don’t understand the fourth line of code of Micropython’s onewire driver [closed]

In the onewire.py driver provided by Micropython, a _onewire module is imported in the fourth line. I don’t understand why an underscore "-" is added before the module name?