Categories
Apple User Help

Unusable 2.5″ external HDD. Partition failed with the error -69760: Unable to write to the last block of the device. Exfat only? Repairable?

Update 1: Somehow, after unconnecting and re-connecting, the original disk (disk1) has now returned to original state, with the readme file as well! I still have another disk which is not working. When connected to my MBP I get the message, “The disk you inserted was not readable by this computer.” “[Initialize | Ignore | Eject]”.

Update 2 (1/3): @Allan’s question: Like how long from when you bought the drives and were working to when they stopped? Answer: They were removed from the packaging on the day they arrived. These are brand new. They both worked out of the box. Issues started after partitioning and attempting to restore via Image.

Update 2 (2/3): I tried what @Allan suggested, diskutil partitionDisk disk2 1 GPT JHFS+ "Untitled" 100% This is what I got:

Started partitioning on disk2
Unmounting disk
Error: -69760: Unable to write to the last block of the device

I stil get the same “The disk you inserted was not readable by this computer.” message upon connecting the drive to the MBP. Moreover, the ‘First Aid’ option in Disk Utility is greyed out.

Update 2 (3/3): As quite rightly pointed out by @Allan, there was too much detail and I’ve now removed most of the details pertaining to the disk that has somehow returned to original state. If there is still too much/little detail please let me know in the comments.

Update 3: sudo diskutil verifyDisk /dev/disk1

Nonexistent, unknown, or damaged partition map scheme
If you are sure this disk contains a (damaged) APM, MBR, or GPT partition
scheme, you might be able to repair it with "diskutil repairDisk /dev/disk1"

diskutil repairDisk /dev/disk1

Nonexistent, unknown, or damaged partition map scheme
If you are sure this disk contains a (damaged) APM, MBR, or GPT partition map,
you can hereby try to repair it enough to be recognized as a map; another
"diskutil repairDisk /dev/disk1" might then be necessary for further repairs
Proceed? (y/N) y
Error repairing map: POSIX reports: Input/output error (5)

Update 4:
sudo gpt -r -v show disk1

gpt show: disk1: mediasize=2000398934016; sectorsize=512; blocks=3907029168
gpt show: unable to open device 'disk1': Input/output error

Update 5:
I used TaskDisk to analyse but it gave me a “Partition: Read Error” message.

Update 6:
As per Allan’s advice I formatted the drive to Exfat on Windows, although the “format did not complete successfully”. On Disk Utility I now can see a greyed-out volume named Disk1s1. However, I still get the message, “The disk you inserted was not readable by this computer.” “[Initialize | Ignore | Eject]”, when connecting to my MBP. Now, diskutil list gives a volume type of DOS_FAT_16. Compare this with the other diskutil list that shows disk1 and disk2 reflecting the original (working) and previous (unusable) state. Next steps from here?






/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *2.0 TB     disk1
   1:                 DOS_FAT_16                         2.0 TB     disk1s1

TL;DR:

I ordered two external hard disks and tried them on the first day they arrived. They appeared to work as a normal external hard drive when I first connected them to my MBP (Retina mid-2015, Yosemite 10.10.3). However, after trying to partition/restore via Disk Utility, they become both unusable. NB. One of them returned to original state — please see Update 1 above.

If these types of 2.5″ external hard disks are actually not compatible with Macs or Time-Machine backups:

A) What can I do to return them back to original usable/exfat state?

B) In their original Exfat state, to what extent will they be usable?

C) Why are they limited to Exfat format?

D) How, without the seller telling me, can I know these are limited to Exfat format only? e.g. Are certain cheap 2.5″ external HDDs from China always limited to Exfat?

Here’s what I’ve had a look at (but not sure if it applies to my case):

http://www.macissues.com/2014/04/05/how-to-fix-deep-formatting-problems-with-os-x-drives/ (I attempted cat /dev/random > /dev/disk1 once only, but got a stdout: Input/output error response)

https://ipfs-sec.stackexchange.cloudflare-ipfs.com/apple/A/question/125965.html (I tried diskutil eraseVolume exfat exfat2tb /dev/disk1 but got the following:

Started erase on disk1
Unmounting disk
Erasing
newfs_exfat: 
wipefs_wipe: Input/output error
Volume name      : exfat2tb
Partition offset : 0 sectors (0 bytes)
Volume size      : 3907029168 sectors (2000398934016 bytes)
Bytes per sector : 512
Bytes per cluster: 131072
FAT offset       : 2048 sectors (1048576 bytes)
# FAT sectors    : 120832
Number of FATs   : 1
Cluster offset   : 122880 sectors (62914560 bytes)
# Clusters       : 15261352
Volume Serial #  : 5ec6682e
Bitmap start     : 2
Bitmap file size : 1907669
Upcase start     : 17
Upcase file size : 5836
Root start       : 18
Mounting disk
Could not mount disk1 with name (null) after erase
Error: -69832: File system formatter failed

Here’s what happened so far:
I first tried to partition one of them. This made it unusable. After attempting to restore the first one by copying/cloning an image from the second one, the second became unusable. Then somehow the first disk randomly became usable again and was back to its original state (it even contained the original readme file).

Context:

I want to do a Time Machine backup to an external hard disk so I bought two 2.5” 2TB external hard disks.

The hard disks (both identical) were described as compatible with macOS, both on packaging and on the online description. I connected one of them for the first time and all looked normal. The only exception is that I found a readme file, which mentioned this drive can only be formatted to Exfat.

When I first ran diskutil list I got the following:

/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *2.0 TB     disk1
   1:               Windows_NTFS WEYOC-2T                2.0 TB     disk1s1

So my conclusion is that the drive is officially in NTFS format, while the readme file says it’s Exfat only and the online description and packaging say’s it’s compatible with Macs. I contacted the seller, who replying saying that it doesn’t work with PS4 and is compatible with Windows, Mac, Xbox and Linux.

So after attempting to partition 1.1GB for Time Machine, Disk Utility gave me the message “Unable to write to last block of device”.

In an attempt to salvage the first disk, I wanted to basically copy/clone the second external drive in its original format and burn it onto the first one that no longer shows a volume. I plugged in the second disk and tried to use the ‘Restore’ function via the Restore tab and clicked on the ‘Image…’ button. I then got a message saying:

“Unable to create “JMicron Generic Media1.dmg.” (Input/output error).”

As per ‘Update 1’ disk1 (which I initially tried to split into a 1.1GB Mac OS Extended (Journaled) partition for Time Machine and 0.9GB Exfat partition for media transfer) has now returned to its original state. And now, running diskutil list with both disks connected (disk1 works, disk2 unusable) gives the following result:

    /dev/disk1
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:     FDisk_partition_scheme                        *2.0 TB     disk1
       1:               Windows_NTFS                         2.0 TB     disk1s1
    /dev/disk2
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                                                   *2.0 TB     disk2

diskutil info /dev/disk2 gives the following:

   Device Identifier:        disk1
   Device Node:              /dev/disk2
   Part of Whole:            disk2
   Device / Media Name:      JMicron Generic Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      None
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               2.0 TB (2000398934016 Bytes) (exactly 3907029168 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                Yes

   Whole:                    Yes
   Internal:                 No
   OS 9 Drivers:             No
   Low Level Format:         Not supported

The first screen shot is what the hard drive first looked like when connected to my MBP. The second shows what it’s like now.


NB. Don’t know if the title/tags best represents the issues I’m facing. Please feel free to suggest a better title/tags in the comments.

NB2. At this stage I don’t know if by trying out random solutions I may end up messing up the drives permanently (if they’re not already messed up).

Leave a Reply

Your email address will not be published. Required fields are marked *