Categories
Linux Mastering Development Ubuntu

Ubuntu 20.04 System doesn’t recognize external microphone

My ubuntu 20.04 doesn’t recognizes external mic with combo jack entry microphone, i nearly tried everything. Here are some information and things i did.

My codec for sound cat /proc/asound/card1/codec* | grep Codec

Codec: Realtek ALC269VC

sudo lshw -c sound shows this;

*-multimedia:0            
   description: Audio device
   product: Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
   vendor: Intel Corporation
   physical id: 3
   bus info: pci@0000:00:03.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=snd_hda_intel latency=0
   resources: irq:33 memory:f7a14000-f7a17fff
*-multimedia:1
       description: Audio device
       product: 8 Series/C220 Series Chipset High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 05
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:34 memory:f7a10000-f7a13fff

Cards that i have with pacmd list-cards

index: 0
    name: <alsa_card.pci-0000_00_03.0>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
            alsa.card = "0"
            alsa.card_name = "HDA Intel HDMI"
            alsa.long_card_name = "HDA Intel HDMI at 0xf7a14000 irq 33"
            alsa.driver_name = "snd_hda_intel"
            device.bus_path = "pci-0000:00:03.0"
            sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
            device.bus = "pci"
            device.vendor.id = "8086"
            device.vendor.name = "Intel Corporation"
            device.product.id = "0c0c"
            device.product.name = "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
            device.form_factor = "internal"
            device.string = "0"
            device.description = "Built-in Audio"
            module-udev-detect.discovered = "1"
            device.icon_name = "audio-card-pci"

Things i added to the /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=basic 
options snd-hda-intel position_fix=1

Model is basic but i tried a lot of things then i found my codecs model in the official documentation of Ubuntu

I tried overriding jack from hdajackretask but when i change something from there i always get the tee: /sys/class/sound/hwC1D0/reconfig: Device or resource is busy even when im not running anything on my system(videos, sound etc.)

Is there any other way to solve this or should i buy a jack to usb transformer?

Leave a Reply

Your email address will not be published. Required fields are marked *