Categories
User Help

Disabling Shift key from overriding Numlock (or stopping Shift key from overriding Numlock for Numpad keys and using Shift as a Numpad 0-9 modifier)

If anyone knows how to disable/override the functionality in Windows of the Shift key temporarily invalidating the Numlock status so that the numpad 0-9 keys output as other keys (insert, end, down, page down, left, clear, right, home, up, page up), I would gladly pay for the solution to this problem. Reason: I have an […]

Categories
Mastering Development System & Network

DD-WRT not routing clients over OpenVPN

I have a Linux router and OpenVPN client at home (running dd-wrt) which is connected to my office network via OpenVPN. From the router itself, I can access my office LAN and its hosts. However, from my home LAN, I can access the internet via my dd-wrt router, but not the Office LAN. My setup […]

Categories
User Help

Disabling Shift key from overriding Numlock (or stopping Shift key from overriding Numlock for Numpad keys and using Shift as a Numpad 0-9 modifier)

If anyone knows how to disable/override the functionality in Windows of the Shift key temporarily invalidating the Numlock status so that the numpad 0-9 keys output as other keys (insert, end, down, page down, left, clear, right, home, up, page up), I would gladly pay for the solution to this problem. Reason: I have an […]

Categories
User Help

Cannot mount nfs at boot but works manually “Network is unreachable” w/ systemd

This is a common question but I’m not finding answers which solve my problem. Debian 10 box will not mount NFS share from /etc/fstab however executing mount -a mounts said share. I noticed a longer boot time. # systemctl status home-user-weather-images.mount ‚óŹ home-user-weather-images.mount – /home/user/weather/images Loaded: loaded (/etc/fstab; enabled-runtime; vendor preset: enabled) Active: failed (Result: […]

Categories
Raspberry Pi User Help

Raspberry Pi does not connect via ethernet or wireless. Remote connection isn’t working

Until recently, my Pi 3B was working perfectly fine on VNC using ethernet with my windows 10 laptop. The problem started after I took out my SD card one day I believe. The IP was still showing up on Advanced IP Scanner at that point but remote connection wasn’t possible, even after putting in another […]

Categories
Mastering Development

Auto leveling 6DOF Unity

I developing an 6DOF game. I have some problems with the auto leveling (so the ship will always goes horizontal). I have new code, the auto leveling worked, but I can’t fly anymore upside down (6DOF). I hope someone can help me. // Update is called once per frame void Update() { yaw = Input.GetAxis("Mouse […]

Categories
Linux Mastering Development

Automatically reconnecting to wifi

Debian 10 without X11. If I turn my AP off and on again then it shows that Debian reconnects, but Debian does not regain network access — for example I can’t ping anything (although I can ping the AP’s IP). In order to get the network to start working again I have to: # ifdown […]

Categories
Mastering Development System & Network

Postfix – outbound SMTP traffic going out wrong interface

I have a postfix server that was working fine (inbound and outbound) until I made some networking changes. I added an interface (for a second public IP address, via a VPN tunnel. I intend to run multiple postfix servers, to support separate domains on separate IP addresses, certificates etc.) After the change, postfix receives inbound […]

Categories
Linux Mastering Development Ubuntu

new homelab server: internal/external network is unreachable

I’m trying to setup a homelab on an HP Proliant ML10 that I’ve installed Ubuntu Server 20.04.1 on. I’m trying to get hooked up to the internet and my local network. I’ve installed net-tools via USB and configured my /etc/network/interfaces configured as follows auto lo iface lo inet loopback # The primary network interface auto […]

Categories
User Help

RHEL7 not assigning link-local IPv6 address to a new network interface

I have written Linux network drivers for a new device. I expect the new interface to get IPv6 link-local address when I insmod the drivers. This works fine on Debian10, CentOS8 and various Ubuntu machines. But RHEL7 doesn’t seem to assign IPv6 address to the interface. So far I have googled "How to disable IPv6 […]