Categories
CMS Mastering Development Wordpress

My custom taxonomy page is leading in 404 page

function wporg_register_taxonomy_instructor() { $labels = [ ‘name’ => _x(‘Instructors’, ‘taxonomy general name’), ‘singular_name’ => _x(‘Instructor’, ‘taxonomy singular name’), ‘search_items’ => __(‘Search Instructors’), ‘all_items’ => __(‘All Instructors’), ‘parent_item’ => __(‘Parent Instructor’), ‘parent_item_colon’ => __(‘Parent Instructor:’), ‘edit_item’ => __(‘Edit Instructor’), ‘update_item’ => __(‘Update Instructor’), ‘add_new_item’ => __(‘Add New Instructor’), ‘new_item_name’ => __(‘New Instructor Name’), ‘menu_name’ => __(‘Instructor’), […]

Categories
CMS Mastering Development Wordpress

custom post type and hidden url : what is the cleanest way to build CPT with custom page template?

I recently built a website were I needed to let user edit the custom post type archive page with elementor. So I decided to use page templates instead of archive pages, that way,I can build my pages with code (custom loop) and elementor (widgets). But after navigating in my website, I spotted strange behaviours. I’m […]

Categories
CMS Mastering Development Wordpress

Invalid Menu Items

I registered a taxonomy named districts, but when I add districts to nav menus, the nav menu items are invalid! Here is the code that registers the taxonomy: function masallah() { // Add new taxonomy, make it hierarchical like categories //first do the translations part for GUI $labels = array( ‘name’ => _x( ‘Districts’, ‘taxonomy […]

Categories
CMS Mastering Development Wordpress

Invalid Menu Items [duplicate]

https://youtu.be/lME3lY-kNbA I told the question on youtube video also I tell the question here again: I cant add my taxonomies to menu except 000 taxonomy.I dont know why but it works: the error : invalid items… ( red showing as you can see on youtube video ) this one works: function deneme() { // Add […]

Categories
CMS Mastering Development Wordpress

Invalid Menu Items – The most interesting question

The question needs it so I captured the error.It is necessary so please watch it. https://youtu.be/lME3lY-kNbA if it doesnt open, please try this: https://www.youtube.com/watch?v=lME3lY-kNbA&feature=youtu.be I told the question on youtube video so I share only the code like what I said on video. I hear that video,video,video are you youtuber? no, it needed this […]

Categories
CMS Development Wordpress

Notice: Undefined property: WP_Error::$name

Latest edit: I opened my youtube chanell for error videos They dont be end.If you want to see my killer errors, you can subscribe it Here is the error: https://youtu.be/wAI4QLlpqDY also ı changed the codes so new codes: //adding taxonomy //hook into the init action and call create_book_taxonomies when it fires add_action( ‘init’, […]

Categories
CMS Development Wordpress

Custom post type defaults to index.php for archive page

I’ve developed a custom theme with a custom post type named events. For some reason, however, WP refuses to use my archive page template with the file name archive-events.php per WP’s template hierarchy. WP keeps defaulting to index.php as the template for this post type. Previously I had a page configured in WP that was […]

Categories
CMS Development Wordpress

Remove custom taxonamy slug with pagination

I have added the custom taxonamy for my faq site. I want to remove the default custom taxonamy showing in url for archive page. I have tried some codes, but it’s break my pagination. function my_taxonomies_faqs() { $labels = array( ‘name’ => _x( ‘FAQ Categories’, ‘taxonomy general name’ ), ‘singular_name’ => _x( ‘FAQ Category’, ‘taxonomy […]

Categories
CMS Development Wordpress

CPT tags not showing when editing post

Since Gutenberg I’ve used the plugin “Classic Editor” for one of my websites until I have time to make the necessary adjustments to fully work with the new Gutenberg look. I’m now starting to look at removing the plugin for the website and noticed an issue that I don’t understand. When editing a custom post […]

Categories
CMS Development Wordpress

CPT tags not showing when editing post

Since Gutenberg I’ve used the plugin “Classic Editor” for one of my websites until I have time to make the necessary adjustments to fully work with the new Gutenberg look. I’m now starting to look at removing the plugin for the website and noticed an issue that I don’t understand. When editing a custom post […]