Categories
Mastering Development

How to use lint-staged in a lerna monorepo to run the same command in all packages?

I have the following root package.json: { "name": "project", "private": true, "workspaces": [ "packages/*" ], "scripts": { "build": "lerna run build", "dev": "lerna run start –stream –parallel", "format": "yarn prettier –write", "prettier": "prettier –ignore-path .gitignore \"**/*.+(ts|tsx|json)\"", "test": "lerna run test –" }, "husky": { "hooks": { "pre-commit": "yarn format && yarn test" } }, "devDependencies": […]

Categories
Mastering Development

Expo Start opens Webpack server automatically instead of opening in expo App

I am trying to open my app inside the expo App. However, when expo starts it opens up the web pack servers instead of leading me to safari inside my Phone 11 simulator. Does anyone know what is wrong? Dependencies below: { "main": "node_modules/expo/AppEntry.js", "scripts": { "start": "expo start", "android": "expo start –android", "ios": "expo […]

Categories
Mastering Development

You may need an appropriate loader to handle this file type, currently no loaders are configured to process file

I just created a project using create-react-app (in javascript). In that, I am linking one of my other repository like this { "name": "hh-frontend-example", "version": "0.1.0", "private": true, "dependencies": { "@testing-library/jest-dom": "^4.2.4", "@testing-library/react": "^9.3.2", "@testing-library/user-event": "^7.1.2", "hh-stylesheet": "file:../hh-stylesheet", "react": "^16.13.1", "react-dom": "^16.13.1", "react-scripts": "3.4.1" }, Here notice this line: "hh-stylesheet": "file:../hh-stylesheet", Now, When I start […]

Categories
Mastering Development

npm ERR! missing script: start error with ReactJS

Have tried all the solutions available but i think this is weird error , Please help me , I am new to reactJS and finding difficult to proceed I tired npm init –yes , no use I also tried npm clean cache and did npm install , still facing error. this is my package.json file. […]

Categories
Mastering Development

Error: No project supports the ‘serve’ target

My package.json file is: { "name": "node-demo", "version": "1.0.0", "description": "demo proxy APIs", "scripts": { "ng": "ng", "build": "ng build –prod", "release-patch": "npm –no-git-tag-version version patch", "test": "ng test", "lint": "ng lint", "e2e": "ng e2e" }, "private": true, "dependencies": { "@angular/animations": "~8.0.0", "@angular/common": "~8.0.0", "@angular/compiler": "~8.0.0", "@angular/core": "~8.0.0", "@angular/forms": "~8.0.0", "@angular/platform-browser": "~8.0.0", "@angular/platform-browser-dynamic": "~8.0.0", "@angular/router": […]

Categories
Mastering Development

Unable to build my Ionic project after installing `ionic cordova plugin add cordova-plugin-fcm-with-dependecy-updated`

I am exploring the firebase post notification. So, I have installed the below packages in my project. After that, I am not able to build my ionic project. $ ionic cordova plugin add cordova-plugin-fcm-with-dependecy-updated $ npm install @ionic-native/fcm I am getting the below error while building my ionic project. > Task :app:transformDexArchiveWithExternalLibsDexMergerForDebug FAILED 35 actionable […]

Categories
Mastering Development

In my react-native application I’m facing an error of > Task :app:mergeDexDebug FAILED

When I install @react-native-firebase/database, @react-native-firebase/app , @react-native-firebase/auth and @react-native-firebase/storage altogether, unistalling either one of them solves the issue but I don’t understand what’s going wrong otherwise as I have to use those packages. The package.json is as follows : { “name”: “ImageExample”, “version”: “0.0.1”, “private”: true, “scripts”: { “android”: “react-native run-android”, “ios”: “react-native run-ios”, “start”: […]

Categories
Mastering Development

Angular9 application app selector html not loading with prod build

I have migrated my angular application from angular8 to 9. package.json { “name”: “visur”, “version”: “1.4.7-alpha.3”, “scripts”: { “ng”: “ng”, “start”: “ng serve”, “build”: “ng build”, “test”: “ng test”, “lint”: “ng lint”, “e2e”: “ng e2e” }, “private”: true, “dependencies”: { “@angular-devkit/build-webpack”: “^0.901.7”, “@angular/animations”: “~9.1.2”, “@angular/cdk”: “^9.0.0”, “@angular/common”: “~9.1.2”, “@angular/core”: “~9.1.2”, “@angular/flex-layout”: “9.0.0-beta.31”, “@angular/forms”: “~9.1.2”, “@angular/http”: […]

Categories
Mastering Development

Angular9 application app selector html not loading with prod build

I have migrated my angular application from angular8 to 9. package.json { “name”: “visur”, “version”: “1.4.7-alpha.3”, “scripts”: { “ng”: “ng”, “start”: “ng serve”, “build”: “ng build”, “test”: “ng test”, “lint”: “ng lint”, “e2e”: “ng e2e” }, “private”: true, “dependencies”: { “@angular-devkit/build-webpack”: “^0.901.7”, “@angular/animations”: “~9.1.2”, “@angular/cdk”: “^9.0.0”, “@angular/common”: “~9.1.2”, “@angular/core”: “~9.1.2”, “@angular/flex-layout”: “9.0.0-beta.31”, “@angular/forms”: “~9.1.2”, “@angular/http”: […]

Categories
Mastering Development

Angular9 application app selector html not loading with prod build

I have migrated my angular application from angular8 to 9. package.json { “name”: “visur”, “version”: “1.4.7-alpha.3”, “scripts”: { “ng”: “ng”, “start”: “ng serve”, “build”: “ng build”, “test”: “ng test”, “lint”: “ng lint”, “e2e”: “ng e2e” }, “private”: true, “dependencies”: { “@angular-devkit/build-webpack”: “^0.901.7”, “@angular/animations”: “~9.1.2”, “@angular/cdk”: “^9.0.0”, “@angular/common”: “~9.1.2”, “@angular/core”: “~9.1.2”, “@angular/flex-layout”: “9.0.0-beta.31”, “@angular/forms”: “~9.1.2”, “@angular/http”: […]