Categories
Linux Mastering Development

USB hard drive on OTG not mounted in Arch Linux

I am trying to mount a USB hard drive (Seagate Backup Plus) via the USB OTG port of my Wandboard on Arch Linux ARM. When I plug in the drive the pilot light flashes several times and Arch Linux finds the device, but finds it as a USB hub: [ 1912.431400] ci_hdrc ci_hdrc.0: new USB […]

Categories
Linux Mastering Development Ubuntu

Ubuntu 14/16/18 install to ASUS T100 fails with I/O error, dumps to initramfs

I have an ASUS T100 on which I am trying to install Ubuntu. I have tried 14, 16, and 18 with similar non-result. Windows 8.1 on this T100 became corrupted, factory reset and windows restore failed, so I decided to make the machine usable again. I am installing from a bootable Patriot memory USB key. […]

Categories
Linux Mastering Development

USB hard drive on OTG not mounted in Arch Linux

I am trying to mount a USB hard drive (Seagate Backup Plus) via the USB OTG port of my Wandboard on Arch Linux ARM. When I plug in the drive the pilot light flashes several times and Arch Linux finds the device, but finds it as a USB hub: [ 1912.431400] ci_hdrc ci_hdrc.0: new USB […]

Categories
Linux Mastering Development

USB hard drive on OTG not mounted in Arch Linux

I am trying to mount a USB hard drive (Seagate Backup Plus) via the USB OTG port of my Wandboard on Arch Linux ARM. When I plug in the drive the pilot light flashes several times and Arch Linux finds the device, but finds it as a USB hub: [ 1912.431400] ci_hdrc ci_hdrc.0: new USB […]

Categories
Linux Mastering Development

USB hard drive on OTG not mounted in Arch Linux

I am trying to mount a USB hard drive (Seagate Backup Plus) via the USB OTG port of my Wandboard on Arch Linux ARM. When I plug in the drive the pilot light flashes several times and Arch Linux finds the device, but finds it as a USB hub: [ 1912.431400] ci_hdrc ci_hdrc.0: new USB […]

Categories
User Help

Unable to enable / configure bluetouth for Lenovo Y520

I have Lenovo Y520 (Legion) with Gentoo and failed to setup bluetouth support. As documentation says: Bluetooth wireless • Combo w/ Wifi card I followed the instruction from https://wiki.gentoo.org/wiki/Bluetooth but still no luck. Linux Kernel: 5.7.8-gentoo Kernel Config: $ cat /usr/src/linux/.config | egrep -i "usb|blue" | grep -v ‘^#’ CONFIG_USB_NET_DRIVERS=y CONFIG_MOUSE_SYNAPTICS_USB=m CONFIG_MEDIA_USB_SUPPORT=y CONFIG_USB_VIDEO_CLASS=m CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y CONFIG_USB_GSPCA=m […]

Categories
Linux Mastering Development

KVM guest unbootable after mkinitramfs – mounting /dev/vda1 on /root failed

25/06/20 Edited: added some additional diag information I have an issue where a KVM guest will work flawlessly up until mkinitramfs is run (Kernel upgrade, Grub cfg change, etc), after which the system fails to boot. Grub menu appears Any selected option from the menu then results in the system failing to the initramfs Busybox […]

Categories
Linux Mastering Development

Thunderbolt – Displayport Monitors not detected on reboot. XPS 13 Arch Linux (endeavourOS)

I am running EndeavourOS (Arch) on a 2017 Dell XPS 13. Kernel 5.7.2-arch1-1 [Hardware name: Dell Inc. XPS 13 9360/02PG84, BIOS 2.13.0 11/14/2019] I have a multi-monitor setup at my desk, that, when working has the following config: xrandr: eDP1 connected primary 1920×1080+0+0 (normal left inverted right x axis y axis) 290mm x 170mm 1920×1080 […]

Categories
Linux Mastering Development

usb 2-6: unable to read config error -71

How do i sort the error below: [ 4.138395] usb 2-6: unable to read config index 0 descriptor/start: -71 [ 4.138400] usb 2-6: can’t read configurations, error -71 My Linux system info Linux 5.3.0-53-generic #47~18.04.1-Ubuntu SMP Thu May 7 13:10:50 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux My dmesg detailed output is below dmesg | grep […]

Categories
Linux Mastering Development

Ubuntu 18.04 / Dell XPS : None of the USB C port works after BIOS reset. Is the USB adapter broken?

After trying to modify few settings on the BIOS, I reset it to Default settings. From this moment, none of the USB ports seems to work : USB key, mouse wireless adapter are not detected as devices. These two devices used to work before the reset. Note : I’m using a USB C – USB […]