Categories
CMS Mastering Development Wordpress

Javascript / Ajax Error After Migrating To New Domain Name

I have migrated a client’s site from their old spammy domain to their new domain that better represents their business. However, since the move, there seems to be some kind of Javascript/Ajax issue. For example, I can’t seem to switch tabs (on ajax pages), and the useful "quick edit" tool doesn’t work at all. When […]

Categories
CMS Mastering Development Wordpress

Error on clicking ‘Screen Options’ tab only at Products-related editor screen(s) and for specific user

My client has problems with the Screen Options tab and in general with Javascript (or maybe WPBakery) related parts of the Admin screen. WPBakery-s blue buttons are not displaying to him at all. And it happens only, if he stays on a Product Editor page or on other screen that is Product-related. MY client’s screenshot: […]

Categories
Mastering Development

go websockets with gorilla libs – unknown json response so can’t map it

I am a newbee, and I am trying to connect to a website that uses websocket for many things, including a chat. my goal is to get only the chat output and do something with that and ignore the rest. I know the json I am expecting for the chat, but not for the rest, […]

Categories
Mastering Development

Sidekiq not processing enqueued jobs on local (no worker on dashboard)

Until I introduced redis it was working fine. To make it production ready I added redis config but now it’s not even working on local. Following are the config details. #config/initializers/redis.rb if Rails.env.test? require “fakeredis” $redis = Redis.new else $redis = Redis.new(Rails.application.config_for(:redis)) end config/redis.yml default: &default timeout: 10 development: <<: *default url: “redis://localhost:6379” config/sidekiq.yml :verbose: […]

Categories
CMS Mastering Development Wordpress

(BAD REQUEST) 400 admin-ajax.php error WordPress

I updated my WordPress to current version as it was very outdated. And now I am getting a bad request browse issue now. /wp-admin/admin-ajax.php:1 Failed to load resource: the server responded with a status of 400 (Bad Request) browser pop up. This only occurs when user is not logged in admin. I checked plugins and […]

Categories
Development

Two pairs of TCP server/client sharing same code, but only one client receives messages

I have two pairs of simple TCP server/client, i.e., one client per server, running on Windows: Servers run in a process (app). Clients run in the other process. Servers keep sending heartbeats (a string) to their paired client. The first pair of server/client run their mainloops in their own threads. Once the first server/client have […]