Categories
Linux Mastering Development Ubuntu

libgegl-0.4-0 package upgrade problem

sudo apt update Hit:1 http://pl.archive.ubuntu.com/ubuntu focal InRelease Hit:2 http://pl.archive.ubuntu.com/ubuntu focal-updates InRelease Hit:3 http://security.ubuntu.com/ubuntu focal-security InRelease Hit:4 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu focal InRelease Hit:5 http://pl.archive.ubuntu.com/ubuntu focal-backports InRelease Reading package lists… Done Building dependency tree Reading state information… Done 1 package can be upgraded. Run ‘apt list –upgradable’ to see it. apt list –upgradable Listing… Done libgegl-0.4-0/focal 1:0.4.18+om-0ubu20.04.18~ppa amd64 [upgradable […]

Categories
Linux Mastering Development Ubuntu

how can I fix gcc and g++. I use desktop Ubuntu version 18.04

sudo apt-get install gcc g++ git gcc-*-aarch64-linux-gnu g++-*-aarch64-linux-gnu libncurses5-dev Reading package lists… Done Building dependency tree Reading state information… Done x ‘g+’ Note, selecting ‘libboost-regex1.58.0’ for regex ‘g+’ Note, selecting ‘xdg-desktop-portal’ for regex ‘g+’ Note, selecting ‘linux-image-unsigned-4.15.0-66-lowlatency’ for regex ‘g+’ Note, selecting ‘python-secretstorage-doc’ for regex ‘g+’ Note, selecting ‘linux-signed-image-generic-lts-vivid’ for regex ‘g+’ Note, selecting ‘linux-signed-image-4.13.0-45-lowlatency’ […]

Categories
Linux Mastering Development Ubuntu

Trying to Install WoeUSB on 20.04, but Missing libwxgtk3.0-0v5?

I’m trying to install woeusb on Kubuntu 20.04LTS, but I seem to be missing a dependency. I have Universe and Multiverse enabled as sources, yet this still happens: root@LesserArk:/home/sarah# apt install woeusb Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have […]

Categories
Linux Mastering Development Ubuntu

Can’t install libqt4-dev on Focal – “Package not available” despite appearing in launchpad

I’m trying to get Geant4 up and running, and one of the required dependencies is to have libqt4-dev. Despite the fact that it appears in launchpad (link), I keep on getting the following error: Package libqt4-dev is not available, but is referred to by another package. This may mean that the package is missing, has […]

Categories
Linux Mastering Development Ubuntu

system-config-kickstart has no installation candidate in Ubuntu 20.04 desktop

I am trying to install system-config-kickstart on my Ubuntu 20.04 Desktop amd64. But the package is not found. How should I install system-config-kickstart on Ubuntu 20.04? I have enabled main, universe, restricted and multiverse repositories and run apt update before trying to install it. Also tried installation from apt-get install system-config-kickstart. Tried searching for the […]

Categories
Linux Mastering Development Ubuntu

system-config-kickstart has no installation candidate in Ubuntu 20.04 desktop

I am trying to install system-config-kickstart on my Ubuntu 20.04 Desktop amd64. But the package is not found. How should I install system-config-kickstart on Ubuntu 20.04? I have enabled main, universe, restricted and multiverse repositories and run apt update before trying to install it. Also tried installation from apt-get install system-config-kickstart. Tried searching for the […]

Categories
Mastering Development System & Network

Debian: Cannot install php7.4-curl — depends not installable

I recently upgraded from debian9 (stretch) to debian10 (buster). Which also includes upgrading to php7.4. For some reason php-curl cannot install. I run apt install php7.4-curl and the error I get is: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable […]

Categories
Linux Mastering Development Ubuntu

Trying to install Docker but getting error

I am using this command to install docker $$sudo apt-get install docker-ce docker-ce-cli containerd.io But i get this error. Reading package lists… Done Building dependency tree Reading state information… Done Package docker-ce is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is […]

Categories
Linux Mastering Development Ubuntu

Dependency Problem with LightWorks. Package libssl1.0.0 is not available

While installing lightworks using gdeb. It prompted for that the package have unmet dependency libssl1.0.0 So i tried installing libssl1.0.0 using the following command in terminal sudo apt install libssl1.0.0 Following message displayed in terminal Package libssl1.0.0 is not available, but is referred to by another package.This may mean that the package is missing, has […]