Categories
Mastering Development

Error* The path to iptables is either not set or incorrect for IPTABLES [/usr/sbin/ip6tables]

I use CSF Firewall of Configserver en several servers. After day 23/03/21 I see a problem in one server with Ubuntu 20.04 *Error* The path to iptables is either not set or incorrect for IPTABLES [/usr/sbin/ip6tables] in /etc/csf/csf.conf at /usr/local/csf/lib/ConfigServer/URLGet.pm line 26. Compilation failed in require at /usr/sbin/csf line 21. BEGIN failed–compilation aborted at /usr/sbin/csf […]

Categories
User Help

Why are my packets going out the wrong interface according to the linux routing table?

I have an Ubuntu Bionic machine with a wifi link; and I have set up a wireguard tunnel on it: # ifconfig lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (Local Loopback) RX packets 5502 bytes 545376 (545.3 KB) RX errors 0 dropped 0 overruns 0 […]

Categories
User Help

static network connection between two debians

I am having a big trouble in setting a simple static connection between two computers (two Debians, say A and B). I know, in principle, how to do it, and have done properly for computers B and C (all Debians). However, configuring A is the main goal. Whenever I connect A to my home router […]

Categories
User Help

Display hostname next to IP on WiFi connection with wpa_supplicant and dhclient

I’m working on a custom Linux OS (built with Yocto) and I use wpa_supplicant to connect with Wi-Fi network and dhclient to get IP address. I can connect to the network and I can see my device from other clients and on the router admin panel, but instead of its name I can see Unknown. […]

Categories
User Help

Using Alfa AWUS036NH on a Raspberry pi 4 running kali linux

I’m having an issue with my raspberry detecting the Alfa antenna I got. I’m trying to configure and get up running the Alfa AWUS036NH on my Kali linux system (Image here. Kali Linux RaspberryPi 2 (v1.2), 3, 4 and 400 (64-Bit)), which is installed on the Raspberry pi 4 model B. When plugging the Alfa […]

Categories
Mastering Development System & Network

docker swarm container bind address other than 0.0.0.0

I got a multi-node docker swarm setup with the following interfaces: 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group […]

Categories
User Help

Using Alfa AWUS036NH on a Raspberry pi 4 running kali linux

I’m having an issue with my raspberry detecting the Alfa antenna I got. I’m trying to configure and get up running the Alfa AWUS036NH on my Kali linux system (Image here. Kali Linux RaspberryPi 2 (v1.2), 3, 4 and 400 (64-Bit)), which is installed on the Raspberry pi 4 model B. When plugging the Alfa […]

Categories
Mastering Development System & Network

Kernel TCP stack not forwarding packets immediately to remote server

I’m trying to figure out why a single HTTP POST request over a re-used TLS connection is still taking roughly twice the roundtrip time (RTT). The client is running on Debian 10.8 within a container on K8s. The RTT from client to remote server is ~175ms. I’m using a simple Rust wrapper over libcurl to […]

Categories
User Help

Using Alfa AWUS036NH on a Raspberry pi 4 running kali linux

I’m having an issue with my raspberry detecting the Alfa antenna I got. I’m trying to configure and get up running the Alfa AWUS036NH on my Kali linux system (Image here. Kali Linux RaspberryPi 2 (v1.2), 3, 4 and 400 (64-Bit)), which is installed on the Raspberry pi 4 model B. When plugging the Alfa […]

Categories
Mastering Development System & Network

arp finds router but ping not successful on ethernet; wlan works

So I do have a really weird issue with my home network. Sometimes my ethernet stops working entirely so I cannot connect to the internet. The wlan stil works in those cases. My routers internal ip address is 192.168.2.1. When the ethernet is not working and the settings are not set manually but DHCP is […]