Categories
Linux Mastering Development

Should I remove these?

I ran sudo apt-get -f install and here was the output: Reading package lists… Done Building dependency tree Reading state information… Done Correcting dependencies… Done The following packages were automatically installed and are no longer required: amd64-microcode apport-symptoms apturl-common autotools-dev binutils-common ca-certificates Plus a lot more The following NEW packages will be installed: default-jre-headless i965-va-driver-shaders […]

Categories
Linux Mastering Development Ubuntu

Error installing libgtk2.0-0 on Xubuntu 19.10 64-bit

I’m trying to install BricsCAD v13 for 64-bit on Xubuntu 16.04, however it has several unresolved 32-bit dependencies. I was able to solve them all except libgtk2.0-0:i386. In order to install it, I first run the following command to dispose of the 32-bit packages: sudo dpkg –add-architecture i386 sudo apt-get update Then I try to […]

Categories
Linux Mastering Development Ubuntu

Unable to install mysql

I ran this command : sudo apt-get install mysql-server and I got this as the output: Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libevent-core-2.1-6 mysql-server-5.7 mysql-server-core-5.7 Suggested packages: mailx tinyca The following NEW packages will be installed: libevent-core-2.1-6 mysql-server mysql-server-5.7 mysql-server-core-5.7 0 upgraded, 4 […]

Categories
Linux Mastering Development

Virtualbox installation problem

root@dejan-LIFEBOOK-AH532-G52:/home/dejan# sudo apt-get install virtualbox Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libgsoap-2.8.60 libvncserver1 virtualbox-dkms Suggested packages: vde2 virtualbox-guest-additions-iso Recommended packages: virtualbox-qt The following NEW packages will be installed: libgsoap-2.8.60 libvncserver1 virtualbox virtualbox-dkms 0 upgraded, 4 newly installed, 0 to remove and 0 not […]

Categories
Development Linux Ubuntu

Any download command is terminated with this error – “Errors were encountered while processing: linux-image-4.15.0-20-generic”

Reading package lists… Done Building dependency tree Reading state information… Done The following packages were automatically installed and are no longer required: android-libext4-utils android-libselinux android-libsepol libf2fs0 Use ‘sudo apt autoremove’ to remove them. The following additional packages will be installed: libappindicator1 libglade2-0 libindicator7 Suggested packages: indicator-application The following packages will be REMOVED: linux-image-4.15.0-20-generic The following […]

Categories
Development Linux Ubuntu

I tried to clean up my system and now I can’t install python 3

I was trying to free up some disk space on my machine and since I was not using python3.5 for any of my projects I decided to remove it manually. I guess I must have done something because shortly after that it was impossible to install the stacer ppa. It then went from bad to […]

Categories
Development Linux MySQL Ubuntu

MySQL version 8 is not installed, although it should

root@vm1:/home/mysql# apt install mysql-common Reading package lists… Done Building dependency tree Reading state information… Done You might want to run ‘apt –fix-broken install’ to correct these. The following packages have unmet dependencies: mysql-server:i386 : Depends: mysql-community-server:i386 (= 8.0.16-2ubuntu18.04) but it is not going to be installe d E: Unmet dependencies. Try ‘apt –fix-broken install’ with […]