Apt-get not working on Linux 18.04.3 LTS – unmet dependencies

I have been trying to install packages using apt-get but it gives me a list of packages that have unmet dependencies. Also, if I try to install anything from the package manager it gives me an error again. Reading package lists… Done Building dependency tree Reading state information… Done Note, selecting ‘node-jstimezonedetect’ for regex ‘node.js’…

Details