Enabling truffle compile optimizer does not change the bytecode output

I am trying to deploy my contract by enabling the optimizer to see how much I can save from the gas costs. I am using truffle for the deployment. In truffle I enable the optimizer by the following setting in truffle-config.js: compilers: { solc: { version: ‘^0.5.0’, settings: { evmVersion: ‘byzantium’ // Default: “petersburg” },…

Details