apache2 and php7.X

Enabling php7.x under Ubuntu18 and apache2.4 gives some warnings: Considering dependency mpm_prefork for php7.3: Considering conflict mpm_event for mpm_prefork: Considering conflict mpm_worker for mpm_prefork: Module mpm_prefork already enabled Considering conflict php5 for php7.3: Enabling module php7.3. I have read about changing to mpm_event and php-fpm but implies convoluted manual configurations, far beyond the easiness of…

Details

APT complains of broken/unmet dependencies for my package, but they are available in my repository. How to fix?

I manage an apt repository, for package PACKAGE, which has dependency (DEPENDENCY<<1.2). Both PACKAGE and DEPENDENCY are available in my repository. We just released a version of DEPENDENCY (version 4.0.0), and now installing the same PACKAGE on a completely clean machine fails with the error: The following packages have unmet dependencies: PACKAGE : Depends: DEPENDENCY…

Details

Ansible create files with user permissions in homedir of existing users

I have homedir of few users like that /home/user1 /home/user2 /home/user(n-1) I need ansible to get list of homedir and create file inside every homedir with correct permission. Now i have this playbook — – hosts: pc070 tasks: – name: Find home find: paths: /home recurse: no file_type: directory register: homedir – name: Create temp…

Details