Cannot disable SELinux by modifying the config file and rebooting

I’m trying to diable SELinux on a virtual environment (because a software component we use recommends it, not because I want to) I have tried setting its status to “disabled” in /etc/selinux/config and rebooting, but unlike other questions where after reboot the config file reverts to “enforcing”, in my case the file is successfully modified,…

Details