Why is conditionally loading a custom plugin’s code only on a specific custom post type causing the site content to disappear?

I’m working on a fill-in-the-blanks plugin (https://github.com/liquidchurch/lqd-notes) which has been working. I realized that the plugin was loading its styles, js, and inserting a div on every page, not just its own custom post type (‘lqdnotes). So I used a simple if statement to ensure the code is only passed if the cpt is present.…

Details

How to upgrade ubuntu 16.04 LTS to 18.04 LTS

I am facing issues in upgrading ubuntu from 16.04 LTS to 18.04 LTS. I followed all online sources but could not pass through the initial stages Got the following error when I tried from the terminal $ /usr/lib/ubuntu-release-upgrader/check-new-release-gtk /usr/lib/ubuntu-release-upgrader/check-new-release-gtk:30: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version(‘Gtk’, ‘3.0’) before import to ensure…

Details