apt-get upgrade of google-cloud-sdk throwing errors

I have not found a way to report these bugs when updating Google Cloud SDK via apt-get on Ubuntu 18.04, so posting them here. Setting up google-cloud-sdk (274.0.0-0) … Compiling platform/bq/third_party/yaml/lib3/__init__.py … File “platform/bq/third_party/yaml/lib3/__init__.py”, line 284 class YAMLObject(metaclass=YAMLObjectMetaclass): ^ SyntaxError: invalid syntax … Processing triggers for google-cloud-sdk (274.0.0-0) … Compiling platform/bq/third_party/yaml/lib3/__init__.py … File “platform/bq/third_party/yaml/lib3/__init__.py”, line…

Details

Host configured with both resolvconf and dnsmasq, restarting dnsmasq keeps pointing to old servers

I have an Ubuntu 16.04.2 LTS host. It is configured to use dnsmasq for DNS forwarding, rather than use resolv.conf populated with nameservers. The configuration is standard wherein resolv.conf just has: nameserver 127.0.0.1 search redacted.searchfield.com The host’s configured /etc/resolv.dnsmasq has 4 nameservers configured. When I restart the dnsmasq service, it points to 3 nameservers that…

Details