Upon using “gem install ncode-syosetu”, i get “ERROR: Failed to build gem native extension.” and “make install failed, exit code 2”

I’m trying to install the NcodeSyosetu module using: gem install ncode-syosetu but the output i get is: Building native extensions. This could take a while… Successfully installed concurrent-ruby-ext-1.0.5 Fetching: expeditor-0.5.0.gem (100%) Successfully installed expeditor-0.5.0 Fetching: mini_portile2-2.1.0.gem (100%) Successfully installed mini_portile2-2.1.0 Fetching: nokogiri-1.6.8.1.gem (100%) Building native extensions. This could take a while… Successfully installed nokogiri-1.6.8.1 Fetching:…

Details

Wget with changing url

I use this piece of code to download and install tomcat on a docker image when running automatic tests. The docker image is Ubuntu. Install tomcat RUN mkdir /usr/local/tomcat RUN wget http://www-us.apache.org/dist/tomcat/tomcat-8/v8.5.50/bin/apache-tomcat-8.5.50.tar.gz -O /tmp/tomcat.tar.gz RUN cd /tmp && tar xvfz tomcat.tar.gz RUN cp -Rv /tmp/apache-tomcat-8.5.50/* /usr/local/tomcat/ The issue is that the link constantly changes, with…

Details