Error changing build sdk in adroid studio

When I change both the targetsSdkVersion and the compileSdkVersion to 26, i get an error. I have tried chnaging it through the Project structure settings, and manually, but it keeps giving me the following error: AAPT: error: resource android:attr/dialogCornerRadius not found. apply plugin: ‘com.android.application’ android { compileSdkVersion 26 defaultConfig { applicationId “com.example.agriplanner3” minSdkVersion 14 targetSdkVersion…

Details

SharePoint Online document cannot be opened after file type changed

In SharePoint Online document library, I have a TXT file. I wrote a program to add a ASPX file as newer version of this file. The program is using SPFile.MoveTo(destFileUrl, SP.MoveOperations.AllowBrokenThickets) to rename the file to aspx, then use SP.FileSaveBinaryInformation to kepp the new files content and file type attribute, finally use SPFile.SaveBinary() to update…

Details

How to safe a product via PHP

I’m trying to safe a new product with variants via php. $product = \Craft::$app->elements->createElement(\craft\commerce\elements\Product::class); $product->typeId = 1; $product->enabled = true; $product->enabledForSite = true; $variant = \Craft::$app->elements->createElement(\craft\commerce\elements\Variant::class); $variant->sku = ‘2304978’; (plus other custom fields) $product->setVariants([$variant]); \Craft::$app->elements->saveElement($product); This code results in an exception. Invalid product ID: 412122 #0 /path/to/craft/vendor/craftcms/commerce/src/elements/Variant.php(895): craft\commerce\elements\Variant->getProduct() #1 /path/to/craft/vendor/yiisoft/yii2/base/Model.php(350): craft\commerce\elements\Variant->beforeValidate() #2 /path/to/craft/vendor/craftcms/cms/src/services/Elements.php(536): yii\base\Model->validate() #3…

Details

Cannot use boinccmd

I am unable to use boinccmd on kali 2019.4. I get the following error # boinccmd boinccmd: symbol lookup error: boinccmd: undefined symbol: _ZN10RPC_CLIENT17exchange_versionsER12VERSION_INFO Is it a bug from Boinc and is this a manageable error? An ldd boinccmd leads to the following output linux-vdso.so.1 (0x00007ffd84514000) libboinc.so.7 => /lib/x86_64-linux-gnu/libboinc.so.7 (0x00007f651afe2000) libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f651afc1000) libstdc++.so.6…

Details

python3.7 with libraries ubuntu 18.04

I need to use a python3.7 in my ubuntu 18.04 (armhf) installation. I have successfully installed python3.7, update alternatives. So python3 provides a python3.7 But when I try to run needed package “mopidy” it fails with error: ImportError: cannot import name ‘_gi’ from ‘gi’ (/usr/lib/python3/dist-packages/gi/__init__.py) Can I somehow update or install a required libraries for…

Details