Connection failed: Buffer is not defined – Error when subscribing to AWS Amplify (graphql) Subscriptions after update to v4.7.0

I have just updated from Amplify-cli 4.0.0 to 4.7.0 and now I am getting these errors when attempting to listen for my subscriptions. {provider: AWSAppSyncRealTimeProvider, error: {…}} provider: AWSAppSyncRealTimeProvider {_config: {…}, socketStatus: 0, keepAliveTimeout: 300000, subscriptionObserverMap: Map(0), promiseArray: Array(0), …} error: errors: Array(1) 0: message: “Connection failed: Buffer is not defined” __proto__: Object length: 1…

Details

How to debug sigfpe when divide-by-zero doesn’t occur

I’m trying to compile ruby with O0 -ggdb3 on sw64—- a alpha-like arch and met a weird SIGFPE error: (gdb) bt #0 0x000002000544463c in __divlu () from /lib/libc.so.6.1 #1 0x0000020001fe6808 in distance_multiply ( d=18446744073709551615, m=1) at regcomp.c:109 #2 0x0000020001ff5a44 in optimize_node_left ( node=0x121f43be0, opt=0x2000db31480, env=0x2000db31678) at regcomp.c:5247 #3 0x0000020001ff4b6c in optimize_node_left ( node=0x122387f60, opt=0x2000db317c0, env=0x2000db319b8)…

Details