Gradle dependencies that were declared without a version failed to resolve

I am doing gradle clean build have my java class @SpringBootTest class DemoApplicationTests { @Test void contextLoads() { } } error: cannot find symbol @Test ^ symbol: class Test location: class DemoApplicationTests Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0. build.gradle buildscript { ext { springBootVersion = ‘2.2.2.RELEASE’ }…

Details

JavaFX on WSL – java.lang.NoClassDefFoundError: javafx/application/Application

I’m following this guide on openjfx.io to compile and run HelloFX.java. Ubuntu 18.04.2 LTS, via Windows Sybsystem For Linux Installed openjdk via apt install openjdk-11-jre Downloaded JavaFX from here, linked from the guide. $ java -version openjdk version “11.0.5” 2019-10-15 OpenJDK Runtime Environment (build 11.0.5+10-post-Ubuntu-0ubuntu1.118.04) OpenJDK 64-Bit Server VM (build 11.0.5+10-post-Ubuntu-0ubuntu1.118.04, mixed mode, sharing) Here’s…

Details