When I need to use dev_dependency

If I need any dependency I use them under dependencies like this dependencies: flutter: sdk: flutter provider: ^3.2.0 http: ^0.12.0+3 get_it: ^3.1.0 connectivity: ^0.4.6 email_validator: ^1.0.4 shared_preferences: ^0.5.4+8 google_maps_flutter: ^0.5.21+14 When I can use packages uder dev_dependencies? I don’t know what I have to see in the packages so that I can decide which dependency…

Details