Pymongo throws “OperationFailure: The key is too long”

After updating MongoDB from version 3.4.17 to 4.0.12 from time to time, when executing mongo.conn.COLLECTION_NAME.find({’email’: [‘1’] * 2000}), while email is a string value, the following error is thrown: File “/usr/local/lib/python2.7/dist-packages/pymongo/cursor.py”, line 787, in count cmd, self.__collation, session=self.__session) File “/usr/local/lib/python2.7/dist-packages/pymongo/collection.py”, line 1600, in _count _cmd, self._read_preference_for(session), session) File “/usr/local/lib/python2.7/dist-packages/pymongo/mongo_client.py”, line 1465, in _retryable_read return func(session,…

Details

Extension attribute ‘neighborhood’ not working when payment method is PayPal standard

I have added an extension attribute via extension_attributes.xml <?xml version=”1.0″ ?> <config xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” xsi:noNamespaceSchemaLocation=”urn:magento:framework:Api/etc/extension_attributes.xsd”> <extension_attributes for=”Magento\Customer\Api\Data\AddressInterface”> <attribute code=”neighborhood” type=”string”/> <attribute code=”reference” type=”string”/> </extension_attributes> <extension_attributes for=”Magento\Quote\Api\Data\AddressInterface”> <attribute code=”neighborhood” type=”string”/> <attribute code=”reference” type=”string”/> </extension_attributes> </config> It shows up when using other payment methods such as OpenPay, I can even see it when making a mock order (extension…

Details

How to load categories and its product in magento 2?

Basically i am writing a PHP script in that script i want to load the categories by category name.When the category is load i want to load its product.For this purpose i have write this code but i cant find a way how to do that.Code is attached below $objectManager = \Magento\Framework\App\ObjectManager::getInstance(); $categoryFactory = $objectManager->get(‘\Magento\Catalog\Model\CategoryFactory’);…

Details

How do I fix “Error 1001. InstallUtilLib.dll: Unknown Error” when installing proprietary software with Wine?

I am installing an orthodontic PMS on Ubuntu 19.04. I can get as far as accepting the EULA and telling the installer to install for either everyone or just myself (roaming vs local), the error pops up either way. The installer allows me to start the installation, but this pops up every time. I have…

Details