Categories
Linux Mastering Development Ubuntu

Mouse not working after suspend, Ubuntu 18.04

was hoping someone here could point me in the right direction. I see similar questions asked on this forum but none seems to match my issue.

I have a (Acer) laptop with Ubuntu 18.04 (Mint 19 to be accurate). I like to use a Logitech wireless mouse with it. As of recently, the mouse doesn’t want to respond after waking from suspend. And, yes, I replaced the battery right away. 🙂 The trackpad and keyboard work thankfully

I have to unplug the mouse dongle and insert it again in one of the other USB ports. Even then it doesn’t fix the issue right away. I have to repeat that step several times before the mouse will finally work again. Or restart completely. As mentioned above, this is a recent issue. The mouse (as well as the rest of the laptop) had behaved flawlessly for months before that.

For all it’s worth, I’ve tried the “rmmod” followed by “modprobe” route for these modules but to no avail: hid_logitech_hidpp hid_logitech_dj

Found some entries in dmesg that might be relevant:

[83667.408609] debugfs: Directory '02' with parent 'devices' already present!
[83667.536945] usb 1-3: new full-speed USB device number 53 using xhci_hcd
[83667.687029] usb 1-3: New USB device found, idVendor=046d, idProduct=c534, bcdDevice=29.01
[83667.687033] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[83667.687035] usb 1-3: Product: USB Receiver
[83667.687037] usb 1-3: Manufacturer: Logitech
[83667.713408] logitech-djreceiver 0003:046D:C534.0053: hidraw1: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-0000:05:00.3-3/input0
[83667.778119] usbhid 1-3:1.1: can't add hid device: -71
[83667.778145] usbhid: probe of 1-3:1.1 failed with error -71
[83667.778282] usb 1-3: USB disconnect, device number 53
[83686.581428] debugfs: Directory '02' with parent 'devices' already present!
[83686.709302] usb 1-5: new full-speed USB device number 54 using xhci_hcd
[83692.325503] debugfs: Directory '02' with parent 'devices' already present!
[83692.453017] usb 1-3: new full-speed USB device number 55 using xhci_hcd
[83711.597849] debugfs: Directory '02' with parent 'devices' already present!
[83711.725352] usb 1-3: new full-speed USB device number 56 using xhci_hcd
[83711.853846] usb 1-3: device descriptor read/64, error -71
[83712.089696] usb 1-3: device descriptor read/64, error -71
[83712.197790] debugfs: Directory '02' with parent 'devices' already present!

Any help is appreciated. Thanks much!

Leave a Reply

Your email address will not be published. Required fields are marked *