Categories
Linux Mastering Development Ubuntu

libgegl-0.4-0 package upgrade problem

sudo apt update
Hit:1 http://pl.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://pl.archive.ubuntu.com/ubuntu focal-updates InRelease   
Hit:3 http://security.ubuntu.com/ubuntu focal-security InRelease    
Hit:4 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu focal InRelease
Hit:5 http://pl.archive.ubuntu.com/ubuntu focal-backports InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

apt list --upgradable
Listing... Done
libgegl-0.4-0/focal 1:0.4.18+om-0ubu20.04.18~ppa amd64 [upgradable from: 0.4.22-3]
N: There is 1 additional version. Please use the '-a' switch to see it

apt list --upgradable -a
Listing... Done
libgegl-0.4-0/focal 1:0.4.18+om-0ubu20.04.18~ppa amd64 [upgradable from: 0.4.22-3]
libgegl-0.4-0/focal,now 0.4.22-3 amd64 [installed,upgradable to: 1:0.4.18+om-0ubu20.04.18~ppa]

sudo apt install libgegl-0.4-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgegl-0.4-0 : Depends: libopenexr23 but it is not installable
E: Unable to correct problems, you have held broken packages.

sudo apt install libopenexr23
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libopenexr23 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libopenexr24:i386 libopenexr24

E: Package 'libopenexr23' has no installation candidate

libgegl-0.4-0 can be upgraded but cant ?
I am on Kubuntu 20.04

Leave a Reply

Your email address will not be published. Required fields are marked *