Categories
Mastering Development

Legacy context API has been detected within a strict-mode tree

{
  "name": "my-app",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@testing-library/jest-dom": "^4.2.4",
    "@testing-library/react": "^9.3.2",
    "@testing-library/user-event": "^7.1.2",
    "bootstrap": "^4.4.1",
    "bootstrap-social": "5.1.1",
    "cross-fetch": "2.1.0",
    "font-awesome": "4.7.0",
    "prop-types": "15.6.0",
    "react": "^16.13.1",
    "react-animation-components": "3.0.0",
    "react-dom": "^16.13.1",
    "react-popper": "0.9.2",
    "react-redux": "5.0.7",
    "react-redux-form": "1.16.8",
    "react-router-dom": "^4.3.1",
    "react-scripts": "3.4.1",
    "react-transition-group": "2.3.0",
    "reactstrap": "5.0.0",
    "redux": "3.7.2",
    "redux-logger": "3.0.6",
    "redux-thunk": "^2.2.0"
  },
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  },
  "eslintConfig": {
    "extends": "react-app"
  },
  "browserslist": {
    "production": [
      ">0.2%",
      "not dead",
      "not op_mini all"
    ],
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
    ]
  }
}

The old API will be supported in all 16.x releases, but applications using it should migrate to the new version.

Please update the following components: Connect(Main), Link, Provider, Route, Router, Switch, Transition

Leave a Reply

Your email address will not be published. Required fields are marked *