Nginx – Not seeing expected values for Host X-Forwarded-For

Following the example here: https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/linux-nginx?view=aspnetcore-3.0#configure-nginx I have the following config in my nginx.conf file for one server. server { listen 443 ssl; #listen 80; server_name local.example.domain.com; location / { proxy_pass http://localhost:30004; proxy_http_version 1.1; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection keep-alive; proxy_set_header Host $host; proxy_cache_bypass $http_upgrade; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; } ssl_certificate ./certs/cert.pem; ssl_certificate_key ./certs/key.pem;…

Errors when installing xrdp on AMI RHEL-7.5_HVM-20180813-x86_64-0-Hourly2-GP2

command used: sudo yum -y install https://archive.fedoraproject.org/pub/archive/epel/7/x86_64/Packages/x/xorgxrdp-0.2.9-1.el7.x86_64.rpm errors: Error: Package: xorgxrdp-0.2.9-1.el7.x86_64 (/xorgxrdp-0.2.9-1.el7.x86_64) Requires: xorg-x11-server-Xorg(x86-64) = 1.20.1 Installed: xorg-x11-server-Xorg-1.20.4-7.el7.x86_64 (@rhel-7-server-rhui-rpms) xorg-x11-server-Xorg(x86-64) = 1.20.4-7.el7 Available: xorg-x11-server-Xorg-1.15.0-7.el7.x86_64 (rhel-7-server-rhui-rpms) xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7 Please suggest something to resolve this dependency issue.

remove 3/min-limit of UFW logging (the clean way)?

since I’m not satisfied with th iptables ansible module (not stateful) I’m trying my way with UFW. Problem is, that UFW limits logging to 3/min which might be enough for nonentusiasts. so my solution (not working) was: copy the modified logging section to /etc/ufw/after.rules (before commit): -A ufw-after-logging-input -j LOG –log-prefix “[UFW BLOCK] ” -A…

Using .htaccess to hide the location and extension of .php file

I’m trying to have all requests going to //my.domain/download?id=xx (be it http or https) be processed by /path/to/my/download.php?id=xx. I’ve tried all sorts of RewriteRule rules to no avail, so there’s no point in me posting anything I have, but this is a WordPress install, so this shouldn’t conflict with WP’s existing rules, which are: <IfModule…