xrdp installation on AMI RHEL-7.5_HVM-20180813-x86_64-0-Hourly2-GP2 produced the following errors

command used: sudo yum -y install https://archive.fedoraproject.org/pub/archive/epel/7/x86_64/Packages/x/xorgxrdp-0.2.9-1.el7.x86_64.rpm errors: Error: Package: xorgxrdp-0.2.9-1.el7.x86_64 (/xorgxrdp-0.2.9-1.el7.x86_64) Requires: xorg-x11-server-Xorg(x86-64) = 1.20.1 Installed: xorg-x11-server-Xorg-1.20.4-7.el7.x86_64 (@rhel-7-server-rhui-rpms) xorg-x11-server-Xorg(x86-64) = 1.20.4-7.el7 Available: xorg-x11-server-Xorg-1.15.0-7.el7.x86_64 (rhel-7-server-rhui-rpms) xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7 Please suggest something to resolve this dependency issue.