Why may a single DNS server be responding two different things for the same query?

I own a domain and configured through Digital Ocean DNS service –does this even matter? I have a CNAME for *.my.domain to ingress.my.domain. When I do a dig command, I get different results, e.g.: ➜ ~ dig abc.my.domain @8.8.8.8 ; <<>> DiG 9.11.3-1ubuntu1.11-Ubuntu <<>> abc.my.domain @8.8.8.8 ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<-…

nginx ignores server_name and default_server

I want to serve two domains from the same IP. This is my config: http { log_format main ‘$server_name $remote_addr – $remote_user [$time_local] “$request” ‘ ‘$status $body_bytes_sent “$http_referer” ‘ ‘”$http_user_agent” “$http_x_forwarded_for”‘; access_log /var/log/nginx/access.log main; sendfile on; tcp_nopush on; tcp_nodelay on; keepalive_timeout 65; types_hash_max_size 2048; include /etc/nginx/mime.types; default_type application/octet-stream; include /etc/nginx/conf.d/*.conf; server { listen 80; listen…

How can I suppress the Old Runlevel warning while installing Strongswan

When I install strongswan and dependent packages using apt install, I get the following warning prompt: This inhibits me from installing strongswan through an automated unattended install script. Therefore, how can I suppress this prompt. I am using Debian 9 Stretch (Version: 4.9.189-3+deb9u2) with kernel: 4.9.0-11-amd64. The APT version is v1.4.9 and strongswan I am…

Javamail: Email leaves successfully from program but is not delivered Windows Server 2012 r2

I am severely stuck on this problem. My program successfully delivers emails from my Windows 10 PC and Windows Server 2012 R2 Essential but sending it through any other Windows Server 2012 versions shows as successfully sent but the email is not delivered. Have tried all combinations of SSL/TLS/No authentication as well as all ports…