Yum fails to respect version requirements for package

I have a problem using yum to resolve dependencies for my project, which consists of multiple RPMs that we build ourselves. I have built an RPM with: Requires: Database-devel = 1.0.0 But when I run: $ yum deplist Release/ConfigLoader-devel-4.0.1-0.191128.123053.g83eb.b.d.el7.x86_64.rpm Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * epel: epel.besthosting.ua package: ConfigLoader-devel.x86_64 4.0.1-0.191128.123053.g83eb.b.d.el7…

Installing gerrit plugin in docker container

When running gerritcodereview/gerrit docker container. Gerrit is installed within the /var/gerrit directoy in the container. But when trying to install plugins by docker cp the plugin .jar file, downloaded from https://gerrit-ci.gerritforge.com/job/plugin-its-jira-bazel-stable-2.16/ into the /var/gerrit/plugins directory, plugins are not showing up in the list amongst installed plugins. Eventhough I restarted the container. I ran gerrit with:…

Should I ask my Twitter plugin users to create their own Twitter App and API Keys to use my plugin?

I am creating my first WordPress plugin. It is a Twitter plugin that uses Twitter API 1.1 and OAuth 2.0 to generate a bearer token and then use that to fetch Tweets from Twitter. The plugin is almost ready to be launched. Right now, the user of the plugin will need to go here: https://developer.twitter.com/en/apps/create…