Unable to deploy, failing on slug prepare/upload

There is an issue in some of our shared environments where deployment fails intermittently on the “Preparing slugs” step. No other details are in the error log. Has anyone experienced this or can think of possible root causes? Deploying applications Starting deployment Preparing slugs E: Failed to upload slugs E: Command ‘[‘ssh’, u’2.xxxxxx.ent.magento.cloud’, ‘sudo /etc/platform/xxxxxx/rebuild_slug.sh…

Admin search for custom post type shows results for everything but my post type

I’ve added a custom post type with this: <?php if ( ! function_exists(‘ordinances’) ) { function ordinances() { $args = array( ‘label’ => __( ‘Ordinance’, ‘text_domain’ ), ‘description’ => __( ‘Ordinances’, ‘text_domain’ ), ‘labels’ => $labels, ‘supports’ => array( ‘title’ ), ‘taxonomies’ => false, ‘hierarchical’ => false, ‘public’ => true, ‘show_ui’ => true, ‘show_in_menu’ =>…

Sorting repository by more than one attribute

I want to sort a repository by more than one attribute. Any ideas of how to achieve this? What I have so far is this: public function getLatestPosts() { return $this->postRepository ->getList($this->buildSearchCriteriaForLatestPosts()) ->getItems(); } private function buildSearchCriteriaForLatestPosts() { $this->prepareSearchCriteriaBuilder(); $this->searchCriteriaBuilder->setPageSize(1); return $this->searchCriteriaBuilder->create(); } private function prepareSearchCriteriaBuilder() { /** @var \Magento\Framework\Api\SortOrder $publishDateOrder */ $publishDateOrder = $this->sortOrderBuilder…